Skip to main content

Alternate Characters

Problem Statement
Shashank likes strings in which consecutive characters are different. For example, he likesABABA, while he doesn't like ABAA. Given a string containing characters A and B only, he wants to change it into a string he likes. To do this, he is allowed to delete the characters in the string.
Your task is to find the minimum number of required deletions.
Input Format
The first line contains an integer T, i.e. the number of test cases. 
The next
 T lines contain a string each.
Output Format
For each test case, print the minimum number of deletions required.
Constraints
1≤T≤10 
1≤ length of string ≤105
Sample Input
5
AAAA
BBBBB
ABABABAB
BABABA
AAABBB
Sample Output
3
4
0
0
4
Explanation
AAAA  A, 3 deletions
BBBBB  B, 4 deletions
ABABABAB  ABABABAB, 0 deletions
BABABA  BABABA, 0 deletions
AAABBB  AB, 4 deletions because to convert it to AB we need to delete 2 A's and 2 B's

import java.util.Scanner;

public class Solution {
    static int numOfDels(String inpStr){
                                char[] chrArray=inpStr.toCharArray();
                                int len=chrArray.length;
                                int count=0;
                                for(int i=0;i<len-1;i++){
                                                if(chrArray[i]==chrArray[i+1]){
                                                                count++;
                                                }
                                }
                                return count;
                }
    public static void main(String[] args) {
        /* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
        Scanner scan=new Scanner(System.in);
        int n=scan.nextInt();
        while(n>0){
                String strInp=scan.next();
                System.out.println(numOfDels(strInp));
        }
        //System.out.println(numOfDels(scan.nex());
    }
}

Score: 30.00
Test Case #0:  0.09s
Test Case #1:  0.09s
Test Case #2:  0.09s
Test Case #3:  0.09s
Test Case #4:  0.14s
Test Case #5:  0.15s
Test Case #6:  0.14s
Test Case #7:  0.24s
Test Case #8:  0.23s
Test Case #9:  0.3s
Test Case #10:  0.3s
Test Case #11:  0.29s
Test Case #12:  0.28s


Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance