Skip to main content

BIG Integer

Problem Statement
In this problem you have to add and multiply huge numbers! These numbers are so big that you can't contain them in any ordinary data types like long integer.
Use the power of Java's BigInteger class and solve this problem.
Input Format
There will be two lines containing two numbers, a and b. The numbers are non-negative and can have maximum 200 digits.
Output Format
Output two lines. The first line should contain a+b, and the second line should contain a×b. Don't print any leading zeros.
Sample Input
1234
20
Sample Output
1254
24680
Explanation
1234+20=1254
1234*20=24680



import java.io.*;
import java.util.*;
import java.math.*;

public class Solution {
    static BigDecimal add(BigDecimal a,BigDecimal b){return a.add(b);}
                static BigDecimal multiply(BigDecimal a,BigDecimal b){return a.multiply(b);          }
    public static void main(String[] args) {
        /* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
        Scanner scan=new Scanner(System.in);
        String str1=scan.next();
        String str2=scan.next();
        System.out.println(add(new BigDecimal(str1),new BigDecimal(str2)));
        System.out.println(multiply(new BigDecimal(str1),new BigDecimal(str2)));
    }
}

Input
Str1=”12312312312312";
str2="2342342342342342";
Output:
2354654654654654
28839650461271347136325514704


 Score: 10.00
Test Case #0:  0.08s
Test Case #1:  0.08s
Test Case #2:  0.09s
Test Case #3:  0.08s
Test Case #4:  0.09s
Test Case #5:  0.08s
Test Case #6:  0.08s
Test Case #7:  0.08s
Test Case #8:  0.09s


Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   p...

change directory (cd) function for an abstract file system ( Java Implementation )

Write a function that provides change directory (cd) function for an abstract file system. Notes: Root path is '/'. Path separator is '/'. Parent directory is addressable as "..". Directory names consist only of English alphabet letters (A-Z and a-z). For example, new Path("/a/b/c/d").cd("../x").getPath() should return "/a/b/c/x". Note: The evaluation environment uses '\' as the path separator. public class Path {     private String path;     public Path(String path) {         this.path = path;     }     public String getPath() {         return path;     }     public Path cd(String newPath) {         //throw new UnsupportedOperationException("Waiting to be implemented."); String[] newP=newPath.split("/");     String[] oldP=path.split("/");     int lnCount=0;     for(String str:newP){     if(st...

Java Abstract Class

Problem Statement A Java abstract class is a class that can't be instantiated, that means you cannot create new instances of an abstract class. It works as a base for subclasses. You should learn about Java Inheritence before attempting this challenge. Following is an example of abstact class: abstract class Book {     String title;     abstract void setTitle(String s);     String getTitle()     {         return title;     } } If you try to create an instance of this class like the following line you will get an error: Book new_novel=new Book(); You have to create another class that extends the abstract class. Then you can create instance of the new class. Notice that   setTitle   method is abstract too and has no body. That means you must implement the body of the that method in the child class. In the editor we have provided ...