Skip to main content

BIG Integer

Problem Statement
In this problem you have to add and multiply huge numbers! These numbers are so big that you can't contain them in any ordinary data types like long integer.
Use the power of Java's BigInteger class and solve this problem.
Input Format
There will be two lines containing two numbers, a and b. The numbers are non-negative and can have maximum 200 digits.
Output Format
Output two lines. The first line should contain a+b, and the second line should contain a×b. Don't print any leading zeros.
Sample Input
1234
20
Sample Output
1254
24680
Explanation
1234+20=1254
1234*20=24680



import java.io.*;
import java.util.*;
import java.math.*;

public class Solution {
    static BigDecimal add(BigDecimal a,BigDecimal b){return a.add(b);}
                static BigDecimal multiply(BigDecimal a,BigDecimal b){return a.multiply(b);          }
    public static void main(String[] args) {
        /* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
        Scanner scan=new Scanner(System.in);
        String str1=scan.next();
        String str2=scan.next();
        System.out.println(add(new BigDecimal(str1),new BigDecimal(str2)));
        System.out.println(multiply(new BigDecimal(str1),new BigDecimal(str2)));
    }
}

Input
Str1=”12312312312312";
str2="2342342342342342";
Output:
2354654654654654
28839650461271347136325514704


 Score: 10.00
Test Case #0:  0.08s
Test Case #1:  0.08s
Test Case #2:  0.09s
Test Case #3:  0.08s
Test Case #4:  0.09s
Test Case #5:  0.08s
Test Case #6:  0.08s
Test Case #7:  0.08s
Test Case #8:  0.09s


Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance