Skip to main content

Java Interface

Problem Statement
A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces.
You are given an interface AdvancedArithmetic which contains a method signature public abstract int divisorSum(int n). You need to write a class called MyCalculator which implements the interface.
divisorSum function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so divisorSum should return 12. Value of n will be at most 1000.
Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only. Your class shouldn't be public.
Sample Input
6
Sample Output
I implemented: AdvancedArithmetic
12
Explanation
Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12.


import java.util.*;
interface AdvancedArithmetic{
  public abstract int divisorSum(int n);
}

​//Solution code
class MyCalculator implements AdvancedArithmetic{
    public int divisorSum(int n){
        int sum=0,i=0,N=n;
        for(i=1;i<=N;i++){
            if(n%i==0) sum=sum+i;
        }
        return sum;
    }
}
//solution code​


class Solution{

    public static void main(String []argh)
    {
       MyCalculator my_calculator=new MyCalculator();
        System.out.print("I implemented: ");
        ImplementedInterfaceNames(my_calculator);
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        System.out.print(my_calculator.divisorSum(n)+"\n");
   }
    /*
     *  ImplementedInterfaceNames method takes an object and prints the name of the interfaces it implemented
    */
    static void ImplementedInterfaceNames(Object o)
    {
​       Class[] theInterfaces = o.getClass().getInterfaces();
        for (int i = 0; i < theInterfaces.length; i++)
        {
           String interfaceName = theInterfaces[i].getName();
            System.out.println(interfaceName);
        }
    }
}

Score: 10.00
Test Case #0:  0.08s
Test Case #1:  0.09s
Test Case #2:  0.08s
Test Case #3:  0.09s
Test Case #4:  0.09s
Test Case #5:  0.09s

Comments

Popular posts from this blog

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance