Skip to main content

Java Interface

Problem Statement
A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces.
You are given an interface AdvancedArithmetic which contains a method signature public abstract int divisorSum(int n). You need to write a class called MyCalculator which implements the interface.
divisorSum function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so divisorSum should return 12. Value of n will be at most 1000.
Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only. Your class shouldn't be public.
Sample Input
6
Sample Output
I implemented: AdvancedArithmetic
12
Explanation
Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12.


import java.util.*;
interface AdvancedArithmetic{
  public abstract int divisorSum(int n);
}

​//Solution code
class MyCalculator implements AdvancedArithmetic{
    public int divisorSum(int n){
        int sum=0,i=0,N=n;
        for(i=1;i<=N;i++){
            if(n%i==0) sum=sum+i;
        }
        return sum;
    }
}
//solution code​


class Solution{

    public static void main(String []argh)
    {
       MyCalculator my_calculator=new MyCalculator();
        System.out.print("I implemented: ");
        ImplementedInterfaceNames(my_calculator);
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        System.out.print(my_calculator.divisorSum(n)+"\n");
   }
    /*
     *  ImplementedInterfaceNames method takes an object and prints the name of the interfaces it implemented
    */
    static void ImplementedInterfaceNames(Object o)
    {
​       Class[] theInterfaces = o.getClass().getInterfaces();
        for (int i = 0; i < theInterfaces.length; i++)
        {
           String interfaceName = theInterfaces[i].getName();
            System.out.println(interfaceName);
        }
    }
}

Score: 10.00
Test Case #0:  0.08s
Test Case #1:  0.09s
Test Case #2:  0.08s
Test Case #3:  0.09s
Test Case #4:  0.09s
Test Case #5:  0.09s

Comments

Popular posts from this blog

change directory (cd) function for an abstract file system ( Java Implementation )

Write a function that provides change directory (cd) function for an abstract file system. Notes: Root path is '/'. Path separator is '/'. Parent directory is addressable as "..". Directory names consist only of English alphabet letters (A-Z and a-z). For example, new Path("/a/b/c/d").cd("../x").getPath() should return "/a/b/c/x". Note: The evaluation environment uses '\' as the path separator. public class Path {     private String path;     public Path(String path) {         this.path = path;     }     public String getPath() {         return path;     }     public Path cd(String newPath) {         //throw new UnsupportedOperationException("Waiting to be implemented."); String[] newP=newPath.split("/");     String[] oldP=path.split("/");     int lnCount=0;     for(String str:newP){     if(st...

COMPUTE number of inversion in an array - ArrayInversionCount

Task description A zero-indexed array A consisting of N integers is given. An  inversion is a pair of indexes (P, Q) such that P < Q and A[Q] < A[P]. Write a function: class Solution { public int solution(int[] A); } that COMPUTES  the number of inversions in A, or returns −1 if it exceeds 1,000,000,000. Assume that: N is an integer within the range [ 0 .. 100,000 ]; each element of array A is an integer within the range [ −2,147,483,648 .. 2,147,483,647 ]. For example, in the following array: A[0] = -1 A[1] = 6 A[2] = 3 A[3] = 4 A[4] = 7 A[5] = 4 there are four inversions: (1,2) (1,3) (1,5) (4,5) so the function should return 4. Complexity: expected worst-case time complexity is O(N*log(N)); expected worst-case space complexity is O(N), beyond input storage (not counting the storage required for input arguments). Elements of input arrays can be modified. // you can also use imports, for example: // import java.util.*; // you can...