Skip to main content

Java String Problem

Problem Statement
A string is traditionally a sequence of characters, either as a literal constant or as some kind of variable. (Wikipedia)
In this problem we will test your knowledge of Java Strings. A string can be declared in following way:
String my_string="Hello World!"
Each elements of a string is called a character. Number of characters in a string is called string length.
In this problem you wil be given two strings A and B as input. They will contain only lower case english letters. You have to answer the following questions:
1.     What is the total length of string A and B?
2.     Is string A lexicographically larger than than B? print "Yes" or "No".
3.     Make first letter of both the strings uppercase and print them in a single line seperated by a space.
[Note: Lexicographic order is also known as alphabetic order dictionary order. So "ball" is smaller than "cat", "dog" is smaller than "dorm" and "dogg". ]
Sample Input
 hello
 java
Sample Output
9
No
Hello Java


import java.io.*;
import java.util.*;

public class Solution {

    static String retSortArray(String a,String b){
        String[] strList=new String[2];
        strList[0]=a;
        strList[1]=b;
        Arrays.sort(strList);
        return strList[0];
    }
    
    static String toUpperFirstLetter(String str){
        char[] chr=str.toCharArray();
        int len=chr.length;
        String retString="";
        for(int i=0;i<len;i++){
            if(i==0){
                retString=retString+chr[i];
                retString=retString.toUpperCase();
            }else{
                retString=retString+chr[i];
            }
        }
        return retString;
    }
    
    public static void main(String[] args) {
        
        Scanner sc=new Scanner(System.in);
        String A=sc.next();
        String B=sc.next();
        /* Enter your code here. Print output to STDOUT. */
        int len=A.length()+B.length();
        String flag=retSortArray(A,B).equals(B)?"Yes":"No";
        System.out.println(len);
        System.out.println(flag);
        System.out.println(toUpperFirstLetter(A)+" "+toUpperFirstLetter(B));
    }
}


·         Testcase 0
Congratulations, you passed this test case!
Input (stdin)
hello
java
Your Output (stdout)
9
No
Hello Java
Expected Output
9
No
Hello Java





 • Score: 4.17 / 5 
Test Case #0:  0.09s
Test Case #1:  0.09s - Failed
Test Case #2:  0.08s
Test Case #3:  0.08s
Test Case #4:  0.09s
Test Case #5:  0.08s
Test Case #6:  0.08s

Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance