Problem Statement
A string is
traditionally a sequence of characters, either as a literal constant or as some
kind of variable. (Wikipedia)
In this problem we will test your knowledge of Java Strings. A
string can be declared in following way:
String
my_string="Hello World!"
Each elements of a string is called a character. Number of
characters in a string is called string length.
In this problem you wil
be given two strings A and B as input. They will contain only lower case english letters. You
have to answer the following questions:
1.
What is the total length of string A and B?
2.
Is string A lexicographically
larger than than B? print "Yes" or "No".
3. Make
first letter of both the strings uppercase and print them in a single line
seperated by a space.
[Note: Lexicographic order is also known as alphabetic order
dictionary order. So "ball" is smaller than "cat",
"dog" is smaller than "dorm" and "dogg". ]
Sample Input
hello
java
Sample Output
9
No
Hello Java
import java.io.*;
import java.util.*;
public class Solution {
static String retSortArray(String a,String b){
String[] strList=new String[2];
strList[0]=a;
strList[1]=b;
Arrays.sort(strList);
return strList[0];
}
static String toUpperFirstLetter(String str){
char[] chr=str.toCharArray();
int len=chr.length;
String retString="";
for(int i=0;i<len;i++){
if(i==0){
retString=retString+chr[i];
retString=retString.toUpperCase();
}else{
retString=retString+chr[i];
}
}
return retString;
}
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
String A=sc.next();
String B=sc.next();
/* Enter your code here. Print output to STDOUT. */
int len=A.length()+B.length();
String flag=retSortArray(A,B).equals(B)?"Yes":"No";
System.out.println(len);
System.out.println(flag);
System.out.println(toUpperFirstLetter(A)+" "+toUpperFirstLetter(B));
}
}
Congratulations, you
passed this test case!
Input (stdin)
hello
java
Your Output (stdout)
9
No
Hello Java
Expected Output
9
No
Hello Java
• Score: 4.17 / 5
Test Case #0: 0.09s
Test Case #1: 0.09s - Failed
Test Case #2: 0.08s
Test Case #3: 0.08s
Test Case #4: 0.09s
Test Case #5: 0.08s
Test Case #6: 0.08s
Comments
Post a Comment