Skip to main content

Funny String

Problem Statement
Suppose you have a string S which has length N and is indexed from 0 to N−1. String R is the reverse of the string S. The string S is funny if the condition |SiSi−1|=|RiRi−1|is true for every i from 1 to N−1.
(Note: Given a string str, stri denotes the ascii value of the ith character (0-indexed) of str. |x| denotes the absolute value of an integer x)
Input Format
First line of the input will contain an integer T. T testcases follow. Each of the next T lines contains one string S.
Constraints
·         1<=T<=10
·         2<=length of S<=10000
Output Format
For each string, print Funny or Not Funny in separate lines.
Sample Input
2
acxz
bcxz
Sample Output
Funny
Not Funny
Explanation
Consider the 1st testcase acxz
here
|c-a| = |x-z| = 2
|x-c| = |c-x| = 21
|z-x| = |a-c| = 2
Hence Funny.
Consider the 2nd testcase bcxz
here
|c-b| != |x-z|
Hence Not Funny.


import java.util.*;


public class Solution {
    static int retValue(char c1,char c2){
              return Math.abs((byte)c1-(byte)c2);
       }
      
       static boolean isFunny(String str){
       boolean retV=true;
       String strRev=new StringBuffer(str).reverse().toString();
       char[] chrArr1=str.toCharArray();
       int len=chrArr1.length;
       char[] chrArr2=strRev.toCharArray();
       for(int i=0;i<len-1;i++){
              if(retValue(chrArr1[i+1],chrArr1[i])!=retValue(chrArr2[i+1],chrArr2[i])){
                     retV = false;
              }
       }
      
       return retV;
    }
    public static void main(String[] args) {
        /* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
        Scanner scan=new Scanner(System.in);
        int n=scan.nextInt();
        while(n>0){
              String inpStr=scan.next();
         if(isFunny(inpStr)){
              System.out.println("Funny");
        }else{
              System.out.println("Not Funny");
        }
              n--;
        }
       
    }
}


Testcase0
Input (stdin)
2
acxz
bcxz
Your Output (stdout)
Funny
Not Funny
Expected Output
Funny
Not Funny

·         Testcase 1
Input (stdin)
2
ivvkxq
ivvkx
Your Output (stdout)
Not Funny
Not Funny
Expected Output
Not Funny
Not Funny



Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance