Skip to main content

Validate an IP Address

Problem Statement
Write a class called myRegex which will contain a string pattern. You need to write a regular expression and assign it to the pattern such that it can be used to validate an IP address. Use the following definition of an IP address:
IP address is a string in the form "A.B.C.D", where the value of A, B, C, and D may range from 0 to 255. Leading zeros are allowed. The length of A, B, C, or D can't be greater than 3.
Some valid IP address:
000.12.12.034
121.234.12.12
23.45.12.56
Some invalid IP address:
000.12.234.23.23
666.666.23.23
.213.123.23.32
23.45.22.32.
I.Am.not.an.ip
In this problem you will be provided strings containing any combination of ASCII characters. You have to write a regular expression to find the valid IPs.
Just write the myRegex class, and we will append your code after the following piece of code automatically before running it:
import java.util.regex.Matcher;
import java.util.regex.Pattern;
import java.util.Scanner;

class Solution{

    public static void main(String []args)
    {
        Scanner in = new Scanner(System.in);
        while(in.hasNext())
        {
            String IP = in.next();
            System.out.println(IP.matches(new myRegex().pattern));
        }

    }
}
(The class written by you MUST NOT be public)
Sample Input
000.12.12.034
121.234.12.12
23.45.12.56
00.12.123.123123.123
122.23
Hello.IP
Sample Output
true
true
true
false
false
false




package org.developersbrain.solutions;
import java.util.*;

public class Solution {
  
       static String[] convertToStringList(String str){
              char[] chrArray=str.toCharArray();
              int noOfDots=0;
              for(int i=0;i<chrArray.length;i++){
                     if(chrArray[i]=='.') noOfDots++;
              }
              String[] retOut=new String[noOfDots+1];
              for(int i=0,j=0;i<chrArray.length;i++){
                     if(j==0&&i==0) retOut[j]="";
                     if(chrArray[i]=='.') {
                           j++;
                           retOut[j]="";
                     }
                     else retOut[j]=retOut[j]+chrArray[i];
              }
              return retOut;
       }
      
       static boolean validateIP(String str){
              boolean retV=false;
              String[] strList=convertToStringList(str);
              int len=strList.length;
              if(len>4 | len<4) retV=false;
              else{
                     for(int i=0;i<len;i++){
                          
                           try{
                                  if(Integer.parseInt(strList[i]) >=0
                          
                                         && Integer.parseInt(strList[i]) <=255
                             ){
                                         retV=true;
                                  }else{
                                         retV=false;
                                         return retV;
                                  }
                                  }catch(Exception e){
                                         retV=false;
                                         return retV;
                                  }
                     }
              }
              return retV;
       }
      
    public static void main(String[] args) {
        Scanner scan=new Scanner(System.in);
        String ipAddr=scan.next();
        System.out.println(validateIP(ipAddr));
    }

}

Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   p...

change directory (cd) function for an abstract file system ( Java Implementation )

Write a function that provides change directory (cd) function for an abstract file system. Notes: Root path is '/'. Path separator is '/'. Parent directory is addressable as "..". Directory names consist only of English alphabet letters (A-Z and a-z). For example, new Path("/a/b/c/d").cd("../x").getPath() should return "/a/b/c/x". Note: The evaluation environment uses '\' as the path separator. public class Path {     private String path;     public Path(String path) {         this.path = path;     }     public String getPath() {         return path;     }     public Path cd(String newPath) {         //throw new UnsupportedOperationException("Waiting to be implemented."); String[] newP=newPath.split("/");     String[] oldP=path.split("/");     int lnCount=0;     for(String str:newP){     if(st...

Calculate the number of elements of an array that are not divisors of each element.

Task description You are given a non-empty zero-indexed array A consisting of N integers. For each number A[i] such that 0 ≤ i < N, we want to count the number of elements of the array that are not the divisors of A[i]. We say that these elements are non-divisors. For example, consider integer N = 5 and array A such that: A[0] = 3 A[1] = 1 A[2] = 2 A[3] = 3 A[4] = 6 For the following elements: A[0] = 3, the non-divisors are: 2, 6, A[1] = 1, the non-divisors are: 3, 2, 3, 6, A[2] = 2, the non-divisors are: 3, 3, 6, A[3] = 3, the non-divisors are: 2, 6, A[6] = 6, there aren't any non-divisors. Write a function: class Solution { public int[] solution(int[] A); } that, given a non-empty zero-indexed array A consisting of N integers, returns a sequence of integers representing the amount of non-divisors. The sequence should be returned as: a structure Results (in C), or a vector of integers (in C++), or a record Results (in Pascal), or...