Skip to main content

Problem: Java Exception Handling

Problem Statement
Create a class myCalculator which consists of a single method power(int,int). This method takes two integers, n and p, as parameters and finds np. If either n or p is negative, then the method must throw an exception which says "n and p should be non-negative".
Please read the partially completed code in the editor and complete it. Your code mustn't be public.
No need to worry about constraints, there won't be any overflow if your code is correct.
Sample Input
3 5
2 4
-1 -2
-1 3
Sample Output
243
16
java.lang.Exception: n and p should be non-negative
java.lang.Exception: n and p should be non-negative


import  java.util.*;
class myCalculator{
    int power(int n,int p) throws java.lang.Exception{
        int power=1;
        while(p>0){
            power=power*(n);
            p--;
        }
       
        if(n==0) power=0;
       
       if(n<0 | p<0){
           throw new java.lang.Exception("n and p should be non-negative");
       }
        else return power;
    }
}

class Solution{
public static void main(String []argh)
    {
        Scanner in = new Scanner(System.in);
        while(in.hasNextInt())
        {
            int n = in.nextInt();
            int p = in.nextInt();
            myCalculator M = new myCalculator();
            try
            {
                System.out.println(M.power(n,p));
            }
            catch(Exception e)
            {
                System.out.println(e);
            }
        }

    }
}

·         Testcase 0
Congratulations, you passed this test case!
Input (stdin)
3 5
2 4
-1 -2
-1 3
Your Output (stdout)
243
16
java.lang.Exception: n and p should be non-negative
java.lang.Exception: n and p should be non-negative
Expected Output
243
16
java.lang.Exception: n and p should be non-negative
java.lang.Exception: n and p should be non-negative


Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Google Cloud Shell | Delete instance