Skip to main content

Expression Validation - Java Stack Problem

Problem Statement
In computer science, a stack or LIFO (last in, first out) is an abstract data type that serves as a collection of elements, with two principal operations: push, which adds an element to the collection, and pop, which removes the last element that was added.(Wikipedia)
A string containing only parentheses is balanced if the following is true: 1. if it is an empty string 2. if A and B are correct, AB is correct, 3. if A is correct, (A) and {A} and [A] are also correct.
Examples of some correctly balanced strings are: "{}()", "[{()}]", "({()})" 
Examples of some unbalanced strings are: "{}(", "({)}", "[[", "}{" etc.
Given a string, determine if it is balanced or not.
Input Format
There will be multiple lines in the input file, each having a single non-empty string. You should read input till end-of-file.
The part of the code that handles input operation is already provided in the editor.
Output Format
For each case, print 'true' if the string is balanced, 'false' otherwise.
Sample Input
{}()
({()})
{}(
[]
Sample Output
true
true
false
true


import java.util.*;
class Solution{
  
    static boolean validateExpression(String str){
        char[] chrArray=str.toCharArray();
        int par=0,cur=0,bra=0;
        for(int i=chrArray.length-1;i>=0;i--){
            if(chrArray[i]==')'){
                par++;
            }else if(chrArray[i]=='}'){
                cur++;
            }else if(chrArray[i]==']'){
                bra++;
            }
           
            if(chrArray[i]=='('){
                par--;
            }else if(chrArray[i]=='{'){
                cur--;
            }else if(chrArray[i]=='['){
                bra--;
            }
        }
        return par==bra && bra==cur;
    }
   
   public static void main(String []argh)
   {
      Scanner sc = new Scanner(System.in);
     
      while (sc.hasNext()) {
         String input=sc.next();
            //Complete the code
            System.out.println(validateExpression(input));
      }
     
   }
}

Input (stdin)
{}()
({()})
{}(
[]
Your Output (stdout)
true
true
false
true
Expected Output
true
true
false
true


• Score: 20.00/20.00
Test Case #0:  0.08s
Test Case #1:  0.08s
Test Case #2:  0.08s


Comments

Popular posts from this blog

Java Interface

Problem Statement A Java interface can only contain method signatures and fields. Interface can be used to achieve polymorphism. In this problem you will practice your knowledge on interfaces. You are given an interface   AdvancedArithmetic   which contains a method signature   public abstract int divisorSum(int n) . You need to write a class called MyCalculator which implements the interface. divisorSum   function just takes an integer as input and return the sum of all its divisors. For example divisors of 6 are 1,2,3 and 6, so   divisorSum   should return 12. Value of n will be at most 1000. Read the partially completed code in the editor and complete it. You just need to write the MyCalculator class only.   Your class shouldn't be public. Sample Input 6 Sample Output I implemented: AdvancedArithmetic 12 Explanation Divisors of 6 are 1,2,3 and 6. 1+2+3+6=12. import java.util.*; interface AdvancedArithmetic{   public abstract int divisorSum(int n

Problem: Java Exception Handling

Problem Statement Create a class myCalculator which consists of a single method power(int,int). This method takes two integers,   n   and   p , as parameters and finds   n p . If either   n   or   p   is negative, then the method must throw an exception which says "n and p should be non-negative". Please read the partially completed code in the editor and complete it. Your code mustn't be public. No need to worry about constraints, there won't be any overflow if your code is correct. Sample Input 3 5 2 4 -1 -2 -1 3 Sample Output 243 16 java.lang.Exception: n and p should be non-negative java.lang.Exception: n and p should be non-negative import  java.util.*; class myCalculator{     int power(int n,int p) throws java.lang.Exception{         int power=1;         while(p>0){             power=power*(n);             p--;         }                 if(n==0) power=0;                if(n<0 | p<0){       

Google Cloud Shell | Delete instance